Elevated Dashboard API Errors
Incident Report for BackupSheep Status
Resolved
This incident has been resolved.
Posted May 08, 2021 - 10:34 EDT
Identified
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted May 04, 2021 - 15:43 EDT
This incident affected: Dashboard.